Monitoring
We are observing successful requests and service seems to be recovering. We are continuing to monitor to ensure service stability.
Identified
We are aware of a service disruption impacting Revolut EU. We have isolated this to an issue on their end, and have escalated to them accordingly. We will update you as more information becomes available.